You have no items in your shopping cart.
NLD Client keeps saying. "System Error. Code: 5. Access is denied."
Please start the NLDapp as Administrator by right-click the application’s shortcut, and then click "Run as an administrator"
iPhone/iPad support?
You can use the NLD MOD Client if your DJI Go App is 4.1.3 or below.
How do I revert back from a newer iOS DJI GO App?
Try this how-to
Do you support Phantom 3?
No support for Phantom 3.
Do you support this or that firmware?
Check our list here.
Does your mods work for my bird?
You download our client from the Download section and use the Guide to set it up. In the "Flight Controller Settings" all the options that are not greyed out, are available for your bird in its current configuration.
Should I update my firmware to one not on your list?
We recommend that you do not update beyond our list, but if in doubt send us an email with your specifics such as your birds firmware version and DJI Go App Version.
Is it possible to downgrade firmware?
Yes, it is possible to downgrade to the firmware versions prior to your current firmware version in DJI Assistant.
I have a bird with a newer firmware than on your list. What do I do?
Try rolling back your firmware. If your firmware, after the firmware rollback, still is not on the list our app will not work on your bird. Then you will have to wait until we release version 1.0.0.3, where you can rollback as far as you want to.
Will your NLD Mod Client on my Spark/Mavic/Phantom 4/Inspire 2
NLD is compatible with DJI Mavic, Spark, Phantom 4, Phantom 4 Adv, Phantom 4 Pro and Inspire 2 and M600 soon.
Do you also provide firmware for controllers
Yes, check the Firmware manager in our NLD Client
Do you have a refund policy and what is it?
There are no refunds so be certain by using the "Does your mods work for my bird?" mention if your bird is supported. If in dobut send us an email with your specifics.
Is it software mod or hardware mod?
The NLD Mod Client is software.
How do you install software mod?
Please check our Guide.
Can I use your software with Mac?
Yes, for now you need to use any virtual machine with Windows. A Mac version is coming soon.
Which windows versions is supported?
Windows 7/8/8.1/10 - 32/64-bit.
Are updates free?
All future mods and updates free of charge.
Can I use Litchi alongside your app?
Yes you can.
Do you acccept WeChat Pay or Alipay?
No we only accept PayPal, but you can use PayPal China and pay with chinese creditcards and/or WeChat Pay.
I lostmy drone or got it replaced and NLD says my key does not work anymore?
Your drone is bound to the serial number so if your drone is replaced then NLD Client because NLD Client does not recognize the new serial number. You will have to buy a new key which is also the reason why the price for a key was set so low so that if you lost it it would be cheap to replace by buying a new key.