Non ci sono articoli nel tuo carrello
venerdì 28 febbraio 2020 06:39:24

NLD Go4 CrystalSky Instructions

4 months ago
#4213 Cita
I love a challenge and CrystalSky has been one. For days I have had all the problems of disappearing NLD Icon. What has worked for me is First you need to go into apps and turn of and clear all data for existing DJI go4 apps. Then follow the instructions on changing  the .XML file. Reboot CS but DO NOT LET DJI go to start initialize .I downloaded Microsoft launcher.apk and installed it making it default launcher. Then I put NLD Icon on first screen. I have not had any problem since. Just can't let dji go4 to start. That I believe is what is reseting the .XML file.

GOOD LUCK to all Hope this helps. Great product
0
4 months ago
#4228 Cita
I found an solution for the disappearing NLD Go Icon!

After i tried all the pssible ways only to find out, that they are not working and after every reboot the Icon disappears, i tried an completely different Way.

My idea was to insert an script in an init.d or init.rc which starts the
su -c "pm enable dji.pilot.pad"

Command on Boot.
But i had the same effect like with the edited *.xml file. After reboot the original files will be restored and nothing happened.

So then i tried another way.

I installed the App Script Manager from Play Store and then i created an file named dji (whatever you name it, it doesnt matter) in
/system/etc/

Then i edited it with script manger and inserted the
su -c "pm enable dji.pilot.pad"
command.
Saved it and make it executable via script manager.
Then i opened it in Script Manager and set it to "executable", "su", and "boot" so that it was executed on Boot with su privileges.
Rebooted the CS.

Aaaannnnndddd......

Voila..
The Icon comes up a few seconds after End of Boot Process and stays present.
I rebooted and powered off the CS several times and still every time the Icon is present and i can start the App.

The only and very sad thing is, that i own an Mavic Air and cannot use the modified App because no support.

Is there an solution for Mavic Air owners in sight?
Is NLD working on an newer Version of App which supports Mavic Air?
0
one month ago
#5026 Cita
thanks forsharing  your solution

I think I found the sytem/etc in the root folder
but the file manager ex  app I use does not write the text file into it


which app did you you use to write the file ? or did I do something wrong ?
0
20 days ago
#5096 Cita
Nicola wrote:
It happens to me too. Did you root the crystal sky? If yes, you can install the application SU Shell Terminal and type the command su -c "pm enable dji.pilot pad". So the DJIGO 4.1.22 NLDCS icon will become visible.
0